4
Vote

Poll Web part not working properly with Foreign language installations

description

While deploying PollingWebpart in a forreign language MOSS with SP1, the POLL list is not created properly and redirects to an Error page. Even if we create the Missing colums in teh poll list, the poll web part doesn't show the options or other controls.

comments

MSteffen wrote Jan 29, 2009 at 11:52 AM

I found the soloution.
The following changes in the code of pollwebpart.cs solve this problem:

In file pollwebpart.cs,
Function ButtonCreatePollList_Click(object sender, System.EventArgs e)
  1. change
                    SPView view = pollsList.Views["All Items"];
    to
                    SPView view = pollsList.Views[0];
    
  2. change
                  SPField field = pollsList.Fields["Title"];
    to
                  SPField field = pollsList.Fields.GetFieldByInternalName("Title");
    
    
    
After these changes the webpart works fine within a german sharepoint portal.

wrote Jan 29, 2009 at 11:53 AM

srouquet wrote Feb 24, 2009 at 3:38 PM

Hi,

Is it possible to release a new version fixing this?

This would be great!

TY

wrote Jun 24, 2009 at 3:24 PM

sasa wrote Jun 24, 2009 at 3:28 PM

I just wanted to submit this as a new issue and then found this item.

We had the same problem with Dutch version of MOSS and fixed it the same way MSteffen did.

sasa wrote Jun 24, 2009 at 3:31 PM

I just wanted to submit this as a new issue and then found this item.

We had the same problem with Dutch version of MOSS and fixed it the same way MSteffen did.

wrote Sep 8, 2010 at 1:41 PM

wrote Feb 14, 2013 at 5:53 PM